Native library for Attach API not available in this JRE

JUnitで、JMockitを使用する場合、JDK1.5以下を使用しているなど、「Native library for Attach API not available in this JRE」とエラーが出た場合はテストごとにjvmに以下の引数を渡してあげてテストを実行する必要があります。

~~にはjmockit.jarのパスを書いてください。

これで、エラーは出なくなります。

Eclipseの「ウィンドウ」-「設定」から「Java」-「インストール済みのJRE」を選択します。

「編集」を押して「JREの編集」ウィンドウを開きます。

Native library for Attach API not available in this JRE

「デフォルトのVM引数」に先ほどの引数を記述します。

関西で140-170/80~120万から受け付けております^^
得意技はJS(ES6),Java,AWSの大体のリソースです
Python3.6,Djangoを勉強中です,Javaは少し飽きてしまってます–;
コメントはやさしくお願いいたします^^
座右の銘は、「狭き門より入れ」「願わくば、我に七難八苦を与えたまえ」です^^

スポンサーリンク
  • このエントリーをはてなブックマークに追加
スポンサーリンク

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA