Apache POIで「Package should contain a content type part [M1.13]」エラー

Excel2003で保存したxlsファイルを拡張子だけxlsxに変更して以下Excel2007用ライブラリで実行してみました。

そうしたら、「import org.apache.poi.xssf.usermodel.XSSFSheet;
import org.apache.poi.xssf.usermodel.XSSFWorkbook;」エラーが発生しました。

content typeがないのが原因っぽく、このエクセルの拡張子を一旦xlsに戻し、xlsx形式で保存しなおします。

そうするとエラーが解消されます。

スポンサーリンク
  • このエントリーをはてなブックマークに追加
スポンサーリンク

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA