Apache POIで「Package should contain a content type part [M1.13]」エラー

求人

Excel2003で保存したxlsファイルを拡張子だけxlsxに変更して以下Excel2007用ライブラリで実行してみました。

そうしたら、「import org.apache.poi.xssf.usermodel.XSSFSheet;
import org.apache.poi.xssf.usermodel.XSSFWorkbook;」エラーが発生しました。

content typeがないのが原因っぽく、このエクセルの拡張子を一旦xlsに戻し、xlsx形式で保存しなおします。

そうするとエラーが解消されます。

関西で140-170/80~120万から受け付けております^^
得意技はJS(ES6),Java,AWSの大体のリソースです
Python3.6,Djangoを勉強中です,Javaは少し飽きてしまってます–;
コメントはやさしくお願いいたします^^
座右の銘は、「狭き門より入れ」「願わくは、我に七難八苦を与えたまえ」です^^

スポンサーリンク
  • このエントリーをはてなブックマークに追加
スポンサーリンク

コメントをどうぞ

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA